Keep getting "No such member" error.

Need help with something ModTweaker - specific? Post it here!

Keep getting "No such member" error.

Postby Linkitch » Fri Apr 10, 2015 6:49 pm

I have several functioning Minetweaker recipes that work flawlessly.

But whenever I try to use any of the ModTweaker supported mod commands, I just get thrown an error:

As an example, I get this error:
No such member: Botania

When trying to use one of the wiki commands:
mods.botania.RuneAltar.addRecipe(<minecraft:stonebrick:2>, [<minecraft:stonebrick>, <minecraft:gunpowder>], 5);

I have these versions installed:
ModTweaker 2-0.7.3

I'm using a semi-public mod pack, and I'm wondering if it is possible that it somehow got disabled? I don't know if that is even possible?
Posts: 1
Joined: Fri Apr 10, 2015 6:33 pm

Re: Keep getting "No such member" error.

Postby molden » Sun Apr 12, 2015 6:45 am

I don't get the error with the wiki command. But your error message says "Botania" with a capital 'B'. The scripts are case sensitive. I know this is a dumb answer but sometimes causes for errors are that dumb.

Also note that if you have any errors in a script it will disable the entire script, so the error you see might not come from the wiki command. This is a pain in the butt because some scripts will make random null or 'modifications were stuck' errors (looking at you NEI) forcing you to restart the game to have the script reenabled.
Posts: 5
Joined: Wed Mar 25, 2015 1:18 am

Re: Keep getting "No such member" error.

Postby Twisted_Code » Sat May 09, 2015 9:29 pm

I keep getting this error when I try using the modTweaker methods for thermal expansion. Whenever I try, I get "No such member: thermalexpansion". I have exactly the same capitalization as I found on the wiki on this page: I even tried what I saw in one of the other threads and tried importing with "import mods.thermalexpansion;", but I still got "no such member" which seems to suggest that there's some discrepancy between the version to which the wiki is updated to and the current version of the mod that I'm using.
Also, why is your own wiki not on the URL whitelist? For that matter, shouldn't the whole domain be on the whitelist?
Posts: 3
Joined: Fri May 08, 2015 2:57 am

Re: Keep getting "No such member" error.

Postby Zyin » Tue Aug 04, 2015 8:03 pm

Make sure your imports are correct.

import mods.botania.RuneAltar;
import mods.botania.ManaInfusion;
Posts: 4
Joined: Tue Aug 04, 2015 7:06 pm

Re: Keep getting "No such member" error.

Postby somebody0214 » Thu Oct 18, 2018 3:32 pm

I get the same problem with the same mod
other mod scripts work perfectly fine
I try import mods.botania.Altar
it replies with ERROR: ?:1 > No such member: botania
and same happens with mods.Botania.ManaInfusion.addInfusion and apothecary as well

ModTweaker - modtweaker-4.0.14
MineTweaker - MineTweaker3-1.7.10-3.0.10B
Botania - Botania r1.8-249

Return to ModTweaker Help

Who is online

Users browsing this forum: No registered users and 6 guests