Mysterious Script Error! Should Work, Doesn't, Help?

Found a bug? Post it here. NOTE - Please post script-specific questions in the scripting help.

Mysterious Script Error! Should Work, Doesn't, Help?

Postby Blue64 » Sat Apr 01, 2017 2:05 am

I'm trying to get 3 Mirriored Recipes to use only ~33 lines of Code, instead of ~90, because I don't want to have 90 separate listings in NEI, if I get this to work it will only create 3 listings, the reason it would take 90 lines doing it the long way is because there's 30 ingredients (I'm creating Recipes to Craft
: [Select all] [/] [] ()
GeSHi © Codebox Plus
from Certus Quartz Dust OreDict (gonna do Red Sand for Nether Quartz Dust next), I don't wanna create a brand new OreDict just to compact the single Recipe (especially since I'm trying to clean up the OreDict in my ModPack), the problem is that I followed the tutorial exactly, and it's still not working, what do I do? Here's a basic snipit of the Code (since it's not being very informative about the Error)

: [Select all] [/] [] ()
var a00 = <minecraft:dye>;
var a01 = <minecraft:dye:4>;
var a30 = [a00, a01];
recipes.addShapedMirrored(<minecraft:sand>*5, [[<ore:dustQuartzCertus>, <ore:dustQuartzCertus>, a30], [<ore: dustQuartzCertus>, a30, <ore: dustQuartzCertus>], [a30, <ore: dustQuartzCertus>, <ore: dustQuartzCertus>]];

# <ore: dustQuartzCertus> contains the various types of Certus Quartz Dust
GeSHi © Codebox Plus

this small snippet of Code should work, but instead throws an Error, help would be VERY much appreciated.
I'm also going to post this to the GitHub repo and Link to here in case this is an unexpected bug since I'm unsure why it's failing.
"Can not IIngredient to IIngredient[]"
"Can not IItemStack to IIngredient[]"
"Can not Any to IIngredient[]"
IDK why it failed.

Re: Mysterious Script Error! Should Work, Doesn't, Help?

Postby Blue64 » Sat Apr 01, 2017 2:34 am

I found this old post in the Closed section, for some reason, when I made the Array a Multi-Line structure, it worked! Not really sure why, but I guess SOMEONE used line returns as an Operator, that should really be a var and not a val (we should be able to use our own Operators).

If anything changes, I'll let y'all know.

Return to Issues and bugs

Who is online

Users browsing this forum: Google [Bot] and 1 guest